Самоучитель по OrCAD

Документация // Самоучитель по OrCAD

 

7.3. Интерфейс программы

В отсутствие ошибок в ПП программа SPECCTRA загружается в режиме трассировки проводников (об этом свидетельствует нажатая пиктограмма.

Программа SPECCTRA управляется с помощью последовательности команд, которые вводятся тремя способами:

  • набирая их с помощью клавиатуры в строке ввода команд Command;
  • запуская на выполнение так называемый Do-файл последовательности команд;

с помощью интерфейса GUI, состоящего из таких элементов, как ниспадающие меню, пиктограммы команд, диалоговые окна.

В нижнем правом углу экрана, имеется панель выбора единиц измерений (изменение единиц измерений сказывается только на отображении результатов на экране и в файлах отчетов и никак не влияет на точность результатов проектирования). Сообщения о результатах выполнения команд выводятся в строке Message. Протокол выполнения команд выводится в нижней части экрана OUTPUT (дублируется в файле сообщений).

На поле режима отображается название текущего режима, например Measure (Измерения) или Move Comp (Перемещение компонента). На полях X, Y указываются текущие координаты курсора. В режиме измерений, в который также можно перейти по команде View>Measure Mode , щелчком левой кнопки указывают начальную точку измерений, координаты текущего положения курсора выводятся в нижней части экрана, а в поле режима после символа А указывается расстояние между начальной точкой и текущим положением курсора.

В режиме Measure также доступна информация об объектах проекта (Component, Pin, Via, Wire segment), помечаемых щелчком левой кнопки мыши. Она выводится в окне OUTPUT; например, для компонента приводятся данные:

Image: LCDDRVR44 - имя корпуса компонента

# Location : (55.8800 91.4400) DBU=(55880 91440) - координаты опорной точки

# Side : Front - расположение на ПП

# Rotate : 90 - угол поворота

Кнопки управления характеризуют фазу работы программы SPECCTRA:

  • Idle — состояние ожидания;
  • Pause — нажатие на кнопку управления в этом состоянии прерывает выполнение текущей команды;
  • Continue — нажатие на эту кнопку продолжает выполнение команды;
  • Stop — нажатие на эту кнопку прекращает выполнение команды;
  • Busy — состояние занятости (выполняются внутренние инструкции).

В процессе размещения компонентов на строке статуса выводится текущая информация:

  • Placed — количество размещенных компонентов, отнесенное к их общему количеству;
  • Selected — количество выбранных компонентов;
  • Locked — количество фиксированных компонентов;
  • Violations — количество нарушений правил размещения компонентов;
  • Ref — позиционное обозначение текущего компонента.

В процессе трассировки проводников на строке статуса выводится другая информация:

  • Pass — количество завершенных проходов трассировки/общее количество проходов;
  • Current Net — имя текущей цепи;
  • Attempts — общее количество попыток повторных трассировок в течение текущего прохода;
  • Reroutes — количество выполненных соединений;
  • Unconnects — количество невыполненных соединений между двумя выводами в течение текущего прохода;
  • Conflicts — количество конфликтов в течение текущего прохода;
  • Completion — количество разведенных цепей в процентах.

Интерфейс программы SPECCTRA поддерживает двух- и трехкнопочную мышь.

Левая кнопка мыши предназначена для измерения расстояний, выбора цепей и других объектов, выполнения интерактивного размещения компонентов и трассировки проводников.

Правая кнопка мыши служит для выбора одного из режимов интерактивного размещения или трассировки (имя текущего режима отображается в нижней части экрана, по умолчанию устанавливается режим измерения расстояний).

В двухкнопочных манипуляторах одновременное нажатие клавиш Alt+npaвая кнопка эквивалентно нажатию средней кнопки трехкнопочной мыши. Нажатие этой кнопки панорамирует изображение, располагая текущее положение курсора в центр экрана. Буксировка мыши по диагонали сверху вниз при нажатой средней кнопке приводит к уменьшению масштаба изображения (эквивалентно команде View>Zoom Out), а буксировка в направлении снизу верх — к увеличению масштаба изображения (эквивалентно команде View>Zoom In). Буксировка мыши при нажатой средней кнопке по горизонтали разворачивает на экран изображение ПП полностью (эквивалентно команде View>Zoom All). Буксировка мыши снизу вверх по вертикали при нажатой средней кнопке разворачивает предыдущее изображение ПП. Эти приемы выполняются только под Windows NT/2000.

Назначения функциональных и «горячих» клавиш, принятые по умолчанию, приведены в табл. 7.1. Самостоятельное программирование «горячих» клавиш производится по команде defkey.

Таблица 7.1. Назначения функциональных и «горячих» клавиш

«Горячая» клавиша

Эквивалентная команда

Назначение

a+Ctrl

repeat_last_menu

Возвращение к последнему меню

Break+Ctrl

quit -c

Завершение работы

c+Ctrl

quit -c

Завершение работы

F3

undo

Откат назад

F3+Shift

redo

Откат вперед

F5

edit_shift_layer_down

Переход на следующий слой ПП

F6

edit_shift_layer_up

Переход на предыдущий слой ПП

F8

set_focus toggle

Переключение назначения «горячих» клавиш

n+Ctrl

popup_form select_nets

Открытие окна Select Nets

p+Ctrl

popup_form initplace_comps

Открытие окна Init Place Large Components

q+Ctrl

repaint

Перечерчивание экрана

r+Ctrl

popup_form route

Открытие меню AutoRoute

z+Ctrl

undo

Откат назад

Простейший способ управлять программой SPECCTRA — использование интерфейса GUI, не требующее знания синтаксиса команд, необходимо только иметь представление о последовательности действий при проектировании ПП, а параметры команд вносятся в поля диалоговых окон (см. разд. 7.4-7.5). Ниже на примере наиболее типичного режима автотрассировки продемонстрируем основные фазы работы с программой.

В окне Routing Setup задается ширина трасс Wire Width низшего приоритета РСВ, устанавливается правило диагональной трассировки Diagonal Route: On (Включить), Off (Выключить), Always (Всегда), задаются правила трассировки цепей Fences (Soft, Hard) и при необходимости устанавливаются размеры сетки проводников (Wire Grid) и ПО (Via Grid). В окне AutoRoute выбирается тип трассировки Smart (устанавливается по умолчанию) и разрешается сглаживание изломов проводников по окончании трассировки Miter After Route. После нажатия клавиш ОК или

По завершении трассировки полезно в окне OUTPUT просмотреть протокол команд, фрагмент которого приведен ниже:

# ============================

# SPECCTRA ShapeBased Automation Software

# Copyright 1990-1999 Cadence Design Systems,

Inc. All Rights Reserved.

# Software licensed for sale by Cadence

Design Systems, Inc.

# Current time = Sun Aug 13 12:18:28 2000

# SPECCTRA ShapeBased Automation Software

V9.0.3 made 2000/03/24 at 16:48:18

# OS Version: WindowsNT 5.0.2195,

Architecture: Intel Pentium II

# Design Name G:\ORCAD_9\tutor1 .dsn

# Did File Name: G:\ORCAD_9\08131218.did

# Current time = Sun Aug 13 12:18:28 2000

# PCB G:\ORCAD_9

# Master Unitset up as: MM 1000

Подробная информация о ходе трассировки и ее результатах выводится по команде Report>Report Status . В нем, в частности, указано: общее количество цепей (Nets) и соединений (Connections) в проекте, количество не разведенных соединений (Unconnections), количество завершенных соединений в процентах (Completion) и информация о каждом проходе трассировки (Pass). В заключение приводятся итоговые данные (WIRING STATISTICS): общее количество ПО (Total Vias), общая длина проводников (Routed length), распределение трасс по сигнальным слоям и др. Более детальные отчеты выводятся по командам меню Report.

Работа с программой в режимах размещения компонентов и трассировки проводников изложены в разд. 7.4-7.5, здесь же отметим, что результаты трассировки записываются в файл по команде File>Write>Routes (по умолчанию ему присваивается имя входного файла с расширением RTE; для продолжения проектирования он может быть загружен в программу SPECCTRA при открытом файле исходной ПП). Результаты размещения компонентов записываются в файл по команде File>Write>Placement (по умолчанию ему присваивается имя входного файла с расширением PLC, для продолжения проектирования может быть загружен в программу SPECCTRA при открытом файле исходной ПП), итоговые результаты проектирования записываются в файл сессии по команде File>Write>Session (по умолчанию ему присваивается имя входного файла с расширением SES, он содержит данные о размещении компонентов и трассировке проводников и может быть загружен в программу SPECCTRA для продолжения проектирования). По завершении разработки ПП достаточно записать ее результаты в файл сессии в любом режиме. После этого можно закончить работу с программой SPECCTRA по команде File>Quit. Если файл сессии не был сохранен, то будет предложено записать его и завершить работу (Save And Quit) или завершить работу без сохранения файла сессии (Quit (No Save)), а также удалить Did-файл протокола команд (этого делать не рекомендуется).